SAP GUI 8 // Altes und Neues Paket

Guten Morgen Zusammen,

ich habe mal wieder eine Frage.
Leider komme ich nicht selber auf die Lösung.

Wir haben aktuell die SAP GUI 8.00 aus dem Service Portal Client im Einsatz.
Nun würde ich gerne auf das PSADT Paket aud dem APD wechseln.
Da sich allerding der Inhalt der SAP GUI Konfig ein wenig verändert hat möchte ich die „alte“ Version gerne erstmal weiterbehalten, damit ich mit der neuen testen kann.
Wenn ich nun die SAP GUI (mit Sourcen und angepasster CFG) per Pipeline importieren möchte schlägt das natürlich fehl, weil ich ja schon eine Version 8.00 im Empirum Paketverzeichnis habe.
Wie kann ich das lösen?
Meine Hoffnung war das irgendwie über das APD vor dem Import die Version verändern kann z.B. als Version 8.01 iportieren oder so.

Vielleicht habe ich auch einfach nur irgendwo einen Denkfehler …

Danke für die Hilfe vorab …

Gruß
Michael

Hallo Michael,

in dem Fall musst Du im heruntergeladene PSADT SAPGUI Paket die Version von 8.00 auf 8.01 ändern, danach noch die neo42PackageConfig.json editieren und auch hier die Version auf 8.0.1 anpassen danach den Ordner 8.0.1 zippen und über die Dateiablage im APC hochladen und anschließen das Paket aus der Dateiablage importieren. Bei mir hat es auf Anhieb funktioniert.

Gruß Alf

2 „Gefällt mir“

Ich komme heute dazu das zu testen. Ich füge in dem schritt auch die sourcen direkt hinzu und importieren dann. So kann ich es auch direkt nach Intune schieben …

Danke vorab. Ich gebe noch Feedback.

Ok. Das hat geklappt.

Eine weitere Frage habe ich noch, vielleicht können Sie mir die aus dem Stehgreif beantworten.
Die Installation ist nicht Silent.
Führe ich die Installation unabhängig von der Softwareverteilung über den SAP Installation Server selber aus mit dem Befehl:
C:\SAP_GUI_Installation_Server\Setup\NwSapSetup.exe /Silent /Package=„XXXXGUI“
läuft die installation komplett silent.

Gruß

Moin Michael,

ich habe gerade einmal nachgesehen. In unserer neo42PackageConfig.json benutzen wir als Parameter /NoDlg /Package="%SAPPACKAGE%"

Du könntest Testweise die Json Datei erneut anpassen und /NoDlg durch /Silent ersetzen oder ergänzen und das Paket dann erneut importieren und testen.

Grüße Alf

2 „Gefällt mir“

Guten Morgen Alf,
das war es. Bin vor Deinem Post schon drüber gestolpert.
Das ist dann allerdings schon länger so das /NoDlg in der Konstellation nicht mehr funktioniert.
Mit /Silent funktioniert es wie es soll.
DANKE!